Skip to main content
← All vulnerabilities
CVE-2025-8678GHSA-35C5-67FM-CPCP

WP Crontrol - 1.17.0 - 1.19.1 - Authenticated (Administrator+) Blind Server-Side Request Forgery

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.19.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The WP Crontrol plugin for WordPress is vulnerable to blind Server-Side Request Forgery in versions 1.17.0 to 1.19.1 via the 'wp_remote_request' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • johnbillion WP Crontrol

    From 1.17.0 · through 1.19.1

  • johnbillion/wp-crontrolPackagist

    From 1.17.0 · fixed in 1.19.2

References 3

wordfence.com

plugins.trac.wordpress.org