Skip to main content
← All vulnerabilities
CVE-2025-8571GHSA-4PCG-PJP5-3MC6

Concrete CMS 9 through 9.4.2 and below 8.5.21 is vulnerable to Reflected Cross-Site Scripting (XSS) in Conversation Messages Dashboard Page

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.4.3, 8.5.21
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Concrete CMS 9 to 9.4.2 and versions below 8.5.21 are vulnerable to Reflected Cross-Site Scripting (XSS) in the Conversation Messages Dashboard Page. Unsanitized input could cause theft of session cookies or tokens, defacement of web content, redirection to malicious sites, and (if victim is an admin), the execution of unauthorized actions. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 4.8 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N. Thanks Fortbridge https://fortbridge.co.uk/  for performing a penetration test and vulnerability assessment on Concrete CMS and reporting this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Concrete CMS Concrete CMS

    From 9.0.0 · fixed in 9.4.3; From 5.6 · fixed in 8.5.21

  • concrete5/concrete5Packagist

    fixed in 8.5.21

  • concrete5/concrete5Packagist

    From 9.0.0RC1 · fixed in 9.4.3

References 4

documentation.concretecms.org

concretecms.org

GitHub · chimdi2700/CVE-2025-8571