Skip to main content
← All vulnerabilities
CVE-2025-71431GHSA-QRQ5-V93P-8XHW

Frappe before 15.86.0 LDAP Injection via Unsanitized Endpoint Parameters

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.99.2, 15.86.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Frappe before 14.99.2 and 15.x before 15.86.0 contains an LDAP injection vulnerability because certain endpoints do not sanitize user-supplied parameters before using them in LDAP queries. Attackers can supply crafted LDAP filter syntax through these parameters to alter the resulting directory queries.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • frappe frappe

    fixed in 14.99.2; From 15.0.0 · fixed in 15.86.0

References 2

GitHub · frappe/frappe

vulncheck.com