Skip to main content
← All vulnerabilities
CVE-2025-71241

SPIP < 4.3.6 Cross-Site Scripting in Private Area

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.20, 4.2.17, 4.3.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

SPIP before 4.3.6, 4.2.17, and 4.1.20 allows Cross-Site Scripting (XSS) in the private area. The content of the error message displayed by the 'transmettre' API is not properly sanitized, allowing an attacker to inject malicious scripts. This vulnerability is mitigated by the SPIP security screen.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • SPIP SPIP

    From 4.1.0 · fixed in 4.1.20; From 4.2.0 · fixed in 4.2.17; From 4.3.0 · fixed in 4.3.6

References 3

blog.spip.net

git.spip.net

vulncheck.com