Skip to main content
← All vulnerabilities
CVE-2025-7053GHSA-J4RJ-FGCQ-WMQP

Cockpit save cross site scripting

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.11.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability was found in Cockpit up to 2.11.3. It has been rated as problematic. This issue affects some unknown processing of the file /system/users/save. The manipulation of the argument name/email leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 is able to address this issue. The patch is named bdcd5e3bc651c0839c7eea807f3eb6af856dbc76. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted very professional. A patch and new release was made available very quickly.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a Cockpit

    2.11.0, 2.11.1, 2.11.2, 2.11.3

  • cockpit-hq/cockpitPackagist

    fixed in 2.11.4

References 5

vuldb.com

GitHub · Cockpit-HQ/Cockpit