Skip to main content
← All vulnerabilities
CVE-2025-6981

Incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed unauthorized read-only access

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.14.15, 3.15.10, 3.16.6, 3.17.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

An incorrect authorization vulnerability allowed unauthorized read access to the contents of internal repositories for contractor accounts when the Contractors API feature was enabled. The Contractors API is a rarely-enabled feature in private preview. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.14.15, 3.15.10, 3.16.6 and 3.17.3

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • GitHub Enterprise Server

    From 3.14.0 · fixed in 3.14.15; From 3.15.0 · fixed in 3.15.10; From 3.16.0 · fixed in 3.16.6; From 3.17.0 · fixed in 3.17.3

References 4

docs.github.com