Skip to main content
← All vulnerabilities
CVE-2025-68455GHSA-255J-QW47-WJH5

Craft CMS vulnerable to potential authenticated Remote Code Execution via malicious attached Behavior

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.8.21, 4.16.17
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via malicious attached Behavior. Note that attackers must have administrator access to the Craft Control Panel for this to work. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • craftcms cms

    From 5.0.0-RC1 · fixed in 5.8.21; From 4.0.0-RC1 · fixed in 4.16.17

  • craftcms/cmsPackagist

    From 5.0.0-RC1 · fixed in 5.8.21

  • craftcms/cmsPackagist

    From 4.0.0-RC1 · fixed in 4.16.17

References 5

GitHub · craftcms/cms