Skip to main content
← All vulnerabilities
CVE-2025-68454GHSA-742X-X762-7383

Craft CMS vulnerable to potential authenticated Remote Code Execution via Twig SSTI

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.8.21, 4.16.17
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Craft is a platform for creating digital experiences. Versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16 are vulnerable to potential authenticated Remote Code Execution via Twig SSTI. For this to work, users must have administrator access to the Craft Control Panel, and allowAdminChanges must be enabled, which is against Craft CMS' recommendations for any non-dev environment. Alternatively, a non-administrator account with allowAdminChanges disabled can be used, provided access to the System Messages utility is available. It is possible to craft a malicious payload using the Twig `map` filter in text fields that accept Twig input under Settings in the Craft control panel or using the System Messages utility, which could lead to a RCE. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • craftcms cms

    From 5.0.0-RC1 · fixed in 5.8.21; From 4.0.0-RC1 · fixed in 4.16.17

  • craftcms/cmsPackagist

    From 5.0.0-RC1 · fixed in 5.8.21

  • craftcms/cmsPackagist

    From 4.0.0-RC1 · fixed in 4.16.17

References 3

GitHub · craftcms/cms