Skip to main content
← All vulnerabilities
CVE-2025-68115GHSA-JHGF-2H8H-GGXVBIT-PARSE-2025-68115

Parse Server vulnerable to Cross-Site Scripting (XSS) via Unescaped Mustache Template Variables

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.6.1, 9.1.0-alpha.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 8.6.1 and 9.1.0-alpha.3, a Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages. The patch, available in versions 8.6.1 and 9.1.0-alpha.3, escapes user controlled values that are inserted into the HTML pages. No known workarounds are available.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • parse-community parse-server

    fixed in 8.6.1; From 9.0.0 · fixed in 9.1.0-alpha.3

  • parse-servernpm

    fixed in 8.6.1

  • parse-servernpm

    From 9.0.0 · fixed in 9.1.0-alpha.3

References 3

GitHub · parse-community/parse-server