Skip to main content
← All vulnerabilities
CVE-2025-67746GHSA-59PP-R3RG-353GBIT-COMPOSER-2025-67746

Composer vulnerable to ANSI sequence injection

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.26, 2.9.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • composer composer

    From 2.0 · fixed in 2.2.26; From 2.3 · fixed in 2.9.3

  • composer/composerPackagist

    From 2.0.0 · fixed in 2.2.26

  • composer/composerPackagist

    From 2.3.0 · fixed in 2.9.3

References 5

GitHub · composer/composer