Skip to main content
← All vulnerabilities
CVE-2025-67723

Discourse vulnerable to stored Cross-site Scripting via Katex in discourse-math plugin

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.5.4, 2025.11.2, 2025.12.1, 2026.1.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • discourse discourse

    fixed in 3.5.4; From 2025.11.0-latest · fixed in 2025.11.2; From 2025.12.0-latest · fixed in 2025.12.1; From 2026.1.0-latest · fixed in 2026.1.0

References 1

GitHub · discourse/discourse