Skip to main content
← All vulnerabilities
CVE-2025-67635GHSA-9P56-P6MW-W8QCBIT-JENKINS-2025-67635

Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes cor

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.541, 2.528.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Jenkins 2.540 and earlier, LTS 2.528.2 and earlier does not properly close HTTP-based CLI connections when the connection stream becomes corrupted, allowing unauthenticated attackers to cause a denial of service.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Jenkins Project Jenkins

    Version range not reported

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.529 · fixed in 2.541

  • org.jenkins-ci.main:cliMaven

    From 2.529 · fixed in 2.541

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.528.3

  • org.jenkins-ci.main:cliMaven

    fixed in 2.528.3

References 1

jenkins.io